Cnc yellow light blinking

Good Morning,

Ive been noticing that when I load a project on the CNC the spindle doesn’t spin up. It loads the values on the screen, but unless I hit the spindle cw f5 button thats flashing yellow, it wont come up to speed. And sometimes even then it will start way too slow and I have to reset the gcode. The rpm in my code for this projec is set at 4000 rpm.

Am I missing something in the steps? I cant seem to find anything about it in the manual. Or is it something with my code maybe?

Also this is unrelated, but what is the default tool number? Sometimes it will pause my program and make me confirm the tool number again, telling me to change tools.

Thank you for the help,


Tool numbers start at 1 normally. As to the start up always check that the actual machine modle is listed as opposed to “large machine” in the vcarve software.

@cafwood @RealCarlRaymond any other ideas ?

I think Brian might be right. Make sure in VCarve when you’re exporting the GCode that the machine selection is “PA-1000” rather than “large machine”. The postprocessor is configured for a machine’s specific features, like “machine-controllable spindle speed”, which ours has, but many others don’t.

Tool numbers are arbitrary, and are specified in the tool library, but the tool number can be overridden in each operation in VCarve when you select it.
You should be sure to use a different number for each different tool in your job, regardless of what’s defined in the library.

But I think what’s happening is you have two different operations in VCarve that use the same tool, but in the settings for each there’s a different tool number for it. That would make Mach4 pause and ask for a tool change.

Side note: managing the tool library is tricky. It lists lots of standard tools that we don’t have, and the two copies of the software don’t use a common library. So we end up adding tools to each, with different parameters. And I don’t know what happens if you create a VCarve project on one computer and move to the other. Can’t be good. I need to figure this out.

1 Like

Awesome! This is all super helpful, thank you both. Next time Im in Ill check those settings and report back if there are any errors.