CNC router behaving oddly, can't use -- FIXED

Team, Group or Volunteer who usually handles this type of ISSUE or REQUEST @RealCarlRaymond

Details of ISSUE or REQUEST (Please be as specific as possible):

I was manually moving the carriage with the arrow keys from Mach 3. Z and Y were fine, but X was random. Pushing either the left or right arrow key made it go right, sometimes left, sometimes not at all.

I unplugged the brain of the CNC and rebooted the computer, and it still behaved the same way

When pressing the right arrow key, my x location on Mach 3 would continue to increase even if the carriage was moving so the left. And if I was pressing the left arrow key and it was moving to the right, the numbers were still going negative. I didn’t watch the numbers when the carriage wasn’t moving at all because I didn’t want to burn anything up.

I manually typed out a basic g-code program, and even then when I told it to go left, it’s still randomly went right

I did not try the remote, the batteries were dead

Please remember that VOLUNTEERS will be helping to resolve this issue. While everyone works very hard to fix things quickly, sometimes things take time. Please consider Volunteering to help keep everything working well in our makerspace!

Hi Evelyn!

After the CNC was most recently fixed with the new drivers, the spindle was not running. Carl fixed it, and that’s when I noticed the same behavior. I let Jimmy/Carl know, I hope it was just a simple wiring mistake!

I opened it up today, and indeed it was just a loose wire. I tightened it down, and checked all the others, and then I ran a full job to completion. It’s working fine now.

Sorry for taking the whole weekend to get to this, but I had a list of other things to finish up first.


Thank you Carl!!

More characters :partying_face::partying_face::partying_face:

1 Like

No worries on the timing, I appreciate the work you put into it!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.